Introduction

Three-dimensional visualization is rapidly becoming a standard means for showing geospatial relationships. The ArcGIS 3D Analyst extension contains a module called ArcScene that allows for the development of rendered 3D environments using standard GIS datasets. This guide assumes that the user has some GIS experience and a basic understanding of ArcMap but has not used the ArcScene module before.

This help guide contains information on the following ArcScene topics:

1 – View a DEM in 3D
2 – Add 3D raster and vector data to the display
3 – Symbolizing layers and adding graphics
4 – Exporting a scene

In order to create a true 3D scene you will need an elevation dataset, which in most cases is a Digital Elevation Model (DEM) raster dataset. Additional vector or raster data is an asset, but not necessary to create a scene.

Part 1 – View a DEM in 3D

View the Data

Open ArcScene from either the Start Menu on your computer or launch ArcScene from the 3D Analyst Toolbar in ArcMap. You may notice that ArcScene appears similar to ArcMap, but contains several different tools and toolbars.

Just like you would in ArcMap, add your DEM to ArcScene using the Add Data button or select File ► Add Data.

It is important to check that a proper coordinate system exists for your data before going any further. Although coordinate systems vary by data source, your dataset should contain some kind of metadata regarding a coordinate system/projection. Very often this information is contained within a text file accompanying the data, or from the website where you may have downloaded the data.

To check the coordinate system, double click Scene Layers in the Table of Contents or click View ► Scene Properties to bring up the Scene Properties window. Click on the Coordinate System tab.

If your data has a known projection, you can skip this step. If the projection is “Unknown” your display may not appear correctly when you attempt to view it in 3D. Using the menu, choose the appropriate coordinate system for your dataset. In the following example, the coordinate system for a DEM of the Vancouver area was changed from “Unknown” to NAD_1983_UTM_Zone_10N (meaning the Universal Transverse Mercator Projected Coordinate System, based on the North American Datum of 1983, Zone 10 North), a common projection for Canadian data.
Don’t panic if your display appears very dark, or washed out in grey. If this is the case you should try setting the Stretch type to something more suitable. Double click on the layer name in the table of contents to bring up the Layer Properties window. Under the Symbology tab, set the Stretch type to “Standard Deviations”.

Also, if desired, under the Symbology tab, set the colour ramp to something more appropriate for your display. For an added effect, you may also add a shaded relief look by checking the box beside “Use hillshade effect”.

![Layer Properties Window](image.png)
Display the Data in 3D

Now you’re ready to add vertical height to your data. In the Layer Properties window, click on the Base Heights tab. Check “Obtain heights from layer surface” and make sure that it is set to your DEM. Click OK.

Depending on the coordinate system you are using, your data may appear rather distorted (as is the case with some Geographic Coordinate Systems). If this is the case for your dataset, you can remedy this by having ArcScene calculate a vertical exaggeration for your data. Vertical exaggeration means that the vertical scale of the display is different than horizontal scale, and this type of exaggeration is typically used in showing subtle topographic differences over large distances.

If your data appears distorted, it is suggested that you double click Scene Layers in the Table of Contents or click View ► Scene Properties to bring up the Scene Properties window. Under the “General” tab, click the “Calculate From Extent” button to have ArcGIS automatically calculate a suitable exaggeration. Click OK. If your data still looks distorted, there may be a problem with the coordinate system you are using.

Even if your original display was not distorted, you may still use the Vertical Exaggeration effect if your area of interest is particularly flat or you simply would like to augment the display. As in the step above, double click Scene Layers in the Table of Contents or click View ► Scene Properties to bring up the Scene Properties window. Under the “General” tab, click the “Calculate From Extent” button to have ArcGIS automatically calculate a suitable exaggeration OR you can also manually set the exaggeration by using the drop-down menu.

In the following example, the user manually set the Vertical Exaggeration to 2, meaning that the vertical scale is displayed 2 times larger than that of the horizontal scale.

Rendering Quality

To adjust the rendering quality of your DEM, double-click the layer name in the Table of Contents and click on the Rendering tab. In the Optimize ”Quality enhancement for raster images” you may adjust the slider bar for a better looking DEM, but beware, high quality rendering may slow drawing time considerably.
There are other options under the Rendering tab that can also be explored to either enhance your display or to increase drawing time.

The following graphic shows a 3D rendered DEM of the Vancouver area.

Note: The DEM in this graphic is a mosaic of four Canadian Digital Elevation Data (CDED) DEM tiles, downloaded freely from www.geobase.ca. In addition to the mosaicking process, the DEM was resampled to a cell size of 20m. All processes were optional and done in ArcMap prior to adding the data to ArcScene.

Part 2 – Add Additional Vector and Raster Data to the 3D Display

Vector and raster data are key components of a 3D GIS scene. Adding data to your ArcScene display is quite similar to adding data in ArcMap, but you can take advantage of a few extra features when creating a quality scene. These include setting base heights, extruding layer height and symbolizing in 3D.

Base Heights

To overlay additional data on your DEM base, such as an orthoimage, modeled surface rasters, or any vector file, use the regular Add Data button.

Open up the Properties window for your data layer and click on the Base Heights tab. Check “Obtain heights from layer surface:” and make sure that it is set to the DEM.

If you are adding a raster image or a vector layer that covers the entire surface of the DEM (think of it like a drape) you can uncheck the DEM layer in the ArcScene table of contents,
since it is not necessary to have ArcScene draw the layer anymore. Notice that any parts of the additional vector/raster data layer that extend beyond the boundary of your DEM surface will not be given height.

The following graphic shows a 3D rendered DEM of the Vancouver area with a vector water polygon layer and a vector road line layer.

![Diagram of 3D rendered DEM of Vancouver area](image)

Note: Vector road and water layers are from the National Topographic Database (NTDB) datasets available for free downloading via Geogratis.

**Extrude Heights for 3D Features**

Features that have a vertical dimension in reality (buildings, fences, etc.) can be drawn in 3D by ArcScene using the Extrusion effect. In the Layer Properties window for your vector feature, click on the Extrusion tab. To add a constant value (each feature will have the same height), change the “Extrusion value or expression” to a value greater than 0. Remember this number is based on the map units of your projection.

If your feature has an attribute field indicating height (or stories), you can have ArcScene represent those values rather than a constant height value. As an example, this help guide will use UWO campus buildings, which contain an integer field indicating the number of STORIES of each building. The coordinate system used is UTM NAD83 Zone 17N, and is therefore represented in metres.

Since stories are not really a definitive height, we will have to estimate how many metres there are in an average building story (something between 3 or 5 will work) and multiply that by the number of stories for each building. This is done by clicking the Expression Builder button and setting up an expression to multiply the number of stories by the
number of metres we determined to be in each story, ex. [STORIES]*4, as in the graphic below. Click OK.

If you have a height field indicating actual height in metres, it would not be necessary to build an expression. Simply apply that field as the extrusion value.

The following graphic shows the UWO campus building footprints, with heights extruded from stories (notice that the buildings are not all the same height):
Part 3 – Symbolizing 3D Layers and Adding Graphics

ArcScene contains a variety of 3D symbols for points, lines and polygon features that can be used to augment a scene. There are many symbols for many different types of features, but for the purposes of this help guide, we will look into one type from each of points, lines and polygons; tree points, fence lines and building polygons. You may also add graphics to add more depth to your 3D scene.

Tree Points

As in Part 2, this example will concentrate on the UWO campus, since the City of London Mapping Data Disc contains tree points for all of the city of London. For this example, we added the Tree Point shapefile and set the base heights to match of DEM of the UWO campus (explained in Part 2). To symbolize the points using pre-existing 3D tree models, open the Layer Properties window for the tree layer and click on the Symbology tab.

Click the Symbol button to bring up Symbol Selector window. Click the More Symbols Button and turn on 3D Trees. Notice that there are a number of different types of 3D symbols that can be used for other features like vehicles, street furniture, etc.
At the top of the Symbol Selector window you can now change the Category to different tree categories. For our trees, we will simply select some type of deciduous tree to represent them all. We will also increase the symbol size, to reflect mature trees. If you have a dataset that includes tree types, size, or other attributes, you can symbolize your trees by category and therefore with greater realism. Our attribute table does not contain these fields, so we will simply use one tree type and size for all points.

Fence Lines

Much the same as the tree points layer, for fences we have a line shapefile with limited attribute data. To symbolize the fence features using pre-existing 3D line textures, open the Layer Properties window and click on the Symbology tab.

Click the Symbol button to bring up Symbol Selector window. Now click the More Symbols Button and turn on 3D Basic. At the top of the Symbol Selector window you can now change the Category to Texture Line.

Select a 3D Textured line that is suitable to your project and click the Properties button. Increase the width and make sure to check the Vertical Orientation checkbox. Click OK.

Building Polygons

As described in Part 2, building polygons first need to be extruded by some value or field to become 3D. To symbolize the extruded 3D building features, you can either select a texture in the Symbology tab, just as you would for any other layer, or use the 3D Buildings toolbar to utilize a custom graphic for your building “walls”.

To add to our UWO buildings example, we would like to portray the walls with a graphic that looks a little more like Western’s style of architecture. To do so, we have created a very simple graphic to use for our building façades. It is a cropped version of an old photograph of a campus building, saved in a Windows Bitmap (*.bmp) format, see below.
ArcScene will apply this graphic to the “walls” of our building polygon by stretching or shrinking the image to fit each wall. If you have more than one graphic, ArcScene will automatically select the better fit (less distortion). Therefore, a better graphic, or series of graphics, should yield better results than our example.

Turn on the 3D Buildings toolbar by selecting View ► Toolbars ► 3D Buildings. On the toolbar, select Convert Features to 3D Buildings.... In the Convert Features window make sure to select your appropriate building polygon feature as the input feature. You can leave the Output Graphics Layer as the default so ArcScene will apply your changes within a new graphics layer.

To change the façades click the … button (see graphic below).

In the 3D Buildings – Texture Palette window, click the Create button. Navigate to your Bitmap file and click OK. Give your new texture group an appropriate name and click OK.

If you double click on your new texture group, you will notice that it contains your graphic and a roof colour option. If desired, double click on the RoofColor to change the colour. If you would like to add another graphic, right click on your texture group name and select Add Image.... Once you are satisfied with your texture palette, click OK.

Make sure to uncheck the Default Facades option. Finally click OK in the Convert features to 3D Buildings window to see the results (you may need to uncheck your original buildings layer in the ArcScene table of contents). The following screenshot shows the intersection of Western Road and Lambton Drive with buildings, fences and trees symbolized in 3D.
Note: The DEM used in this graphic is a MNR v2.0 DEM, resampled to a cell size of 3m and the orthoimage is a tile from the 2006 Southwestern Ontario Orthoimagery Project (SWOOP). Tree points, fence lines and building footprints are from the 2006 City of London Mapping Data Disc. Height a building is based on information given from UWO Physical Plant. All data used in this graphic are available to UWO community members; please visit the Map Library for access to the data.

For advanced users, custom 3D building models can be created in programs such as Google Sketchup and imported into ArcScene, but this is beyond the scope of this help guide.

**Adding Graphics**

You can also add many different types of graphics to your scene to enhance the realism. Examples are cars, street furniture, vegetation, etc. You can also add 3D building graphics and trees manually, in case you did not have a shapefile for these features.

Turn on the Graphics Toolbar by selecting View ► Toolbars ► 3D Graphics. On the toolbar, select Graphics and create a New Graphics Layer. Notice that a new layer has appeared in the ArcScene table of contents. You can rename your graphics layer to something more appropriate.

To add graphics, activate the point, line or polygon button on the toolbar and draw your feature somewhere in the scene. To change the symbology of the feature, right click on it and select Properties.
The following screenshot shows the intersection of Western Road and Lambton Drive with graphics included for automobiles, shrubs, traffic lights, a bus shelter, a fire hydrant, and a newspaper stand.

**Part 4 - Exporting a Scene**

To export your scene as a static 2D image, select File ► Export Scene ► 2D.... There are a number of different image formats available.

In the Options area of the Export Map window, under the General tab you will be able set the output resolution, which describes the detail an image holds. Higher resolution means more image detail.

To change the size of the output image, adjust the Screen Size pixel count. A higher pixel count means a larger image; see the graphic below.
You can also export a scene to a Virtual Reality Modeling Language (VRML) 3D interactive format. However, you will need the appropriate VRML viewers or browser plug-ins to view these types of files.

You can also use the Animation Toolbar to create an animation and save it as a movie file, but that is beyond the scope of this tutorial.